月度归档:一月 2013

对404页面的感想

在我从事网页设计的初期,在繁杂的工作压力下,是不知道SEO为何物的,能把一大堆页面维护好不出错已经很好了,别人在乎的也只是你设计的页面是不是漂亮。老板们口中经常提及的也只是Alexa排名。然而渐渐的,开始有人提出要把404页面作为网站标准配置,在这股热潮下大部分人所做的就是把系统默认的那个报错页面替换一下。但就是有一些PM似乎是找到了风水宝地一样,要求在404页面上放了大量的广告,还放了很多注册充值的链接。。。这一股风刮过后,那些PM就不再过问404了,就仿佛它们从不存在一样。现在点击老东家的网站,尽管主站已经改版了多次,404页面还是N年前那个(点这里)。最要命的是经过后来的几次服务器搬家设置,它已经起不到404的作用了,打其他网址进去,只给你一行冰冷的服务器报错信息… 查看详细 »

兼容几乎所有浏览器的CSS背景透明

以前喜欢用PNG图片做背景透明,在IE6下再加个htc才能做到全兼容,每次要改透明度就得重新做一张PNG,比较麻烦。这里找到一个比较简便的方法,不用加载图片,缺点是CSS长了点(要满足兼容性,长也是正常的),不过能节约时间。

原理是在旧版IE中用滤镜,在IE9以后支持CSS3的浏览器中用RGBA色,包含了透明度值,CSS代码如下 查看详细 »

WordPress插件-多语种切换插件qTranslate使用心得

qTranslate是一款能让你的网站支持多语种切换的轻便插件,可以到qTranslate的作者官网下载这个插件。我已经在自己做的十多个WordPress网站上使用这款插件,是时候总结一下基本的用法和小技巧了。


1. qTranslate版本问题

这款插件在安装后,如果你的WP版本比插件对应版本新,那么每次编辑文章和页面的时候插件会自动禁用自己,要点一下重新使用(其实很多插件都这样),比较麻烦。解决办法是去官网的下载页面先看一下你使用的WP是否能对应上当前安装的插件版本,如果插件过旧就下载最新的插件。但如果最新版的插件还不支持当前版本的WP,你可以自己手动修改WP的版本号。(这个办法适用于不准备频繁升级自己的WordPress版本的人,升级也是种折腾,如果你的站点用了很多插件,升级WP的版本本身就可能会导致各种问题。) 查看详细 »